redundantny tunel IPv6 od HE z HSRP

jedną z ciekawych, a rzadko spotykanych konfiguracji jest możliwość zestawienia tunelu z interfejsu należącego do grupy HSRP.

pozwala to np. w sytuacji gdy macie dwa routery brzegowe, zestawić jeden tunel do Hurricane Electric aby zapewnić sobie możliwość transmisji IPv6 (tunelowanej, ale jednak). tunel będzie aktywny tylko z routera który jest aktualnie domyślną bramką - i to już. przykład poniżej zawiera zatem konfigurację tunelu IPv6 ponad IPv4, ale tak naprawdę rodzaj tunelu nie ma znaczenia.

konfiguracja zawiera testową sieć IPv4 z RFC 6890 używaną jako hipotetyczną ‘publiczną - wykrojoną z podsieci 198.51.100.0/24; tunel musi być zestawiony z publicznej adresacji, ponieważ headend HE musi być w stanie osiągnąć Twoj adres IP przez internet

konfiguracja zawiera testową sieć IPv6 z RFC 6890 jako segment /64 pomiędzy naszymi routerami a routerem HE - konfigurując usługę otrzymujesz pełen zestaw adresów które należy skonfigurować oraz adres który trzeba wskazać jako domyślna trasa - zwykle kończy się na ::1 a Twoje routery otrzymają końcówkę ::2; jeśli poprosisz HE o wyroutowanie dodatkowej /48 za swój tunel, HE będzie kierował ruch do ::2 - oba routery po twojej stronie muszą mieć zatem skonfigurowany ten sam adres

poglądowo, można to przedstawić następująco (polecam ASCIIflow do szybkich i trzymających proporcje rysunków):

Przykładowa sieć z tunelem IPv6oIP z HSRP

przykładowa konfiguracja dwóch routerów:

HSRP-1#sh run int gi1
!
interface GigabitEthernet1
 ip address 198.51.100.1 255.255.255.0
 standby 0 ip 198.51.100.3
 standby 0 priority 105 ! świadomie kontrolujemy który router
                        ! będzie aktywny w normalnej sytuacji
end

HSRP-2#sh run int gi1
!
interface GigabitEthernet1
 ip address 198.51.100.2 255.255.255.0
 standby 0 ip 198.51.100.3
end

grupa HSRP powinna pokazać nam HSRP-1 jako aktywny:

HSRP-1#sh standby 
GigabitEthernet1 - Group 0
  State is Active
    2 state changes, last state change 00:00:31
  Virtual IP address is 198.51.100.3
  Active virtual MAC address is 0000.0c07.ac00 (MAC In Use)
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.528 secs
  Preemption disabled
  Active router is local
  Standby router is 198.51.100.2, priority 100 (expires in 9.120 sec)
  Priority 105 (configured 105)
  Group name is "hsrp-Gi1-0" (default)

HSRP-2#sh standby 
GigabitEthernet1 - Group 0
  State is Standby
    4 state changes, last state change 00:00:15
  Virtual IP address is 198.51.100.3
  Active virtual MAC address is 0000.0c07.ac00 (MAC Not In Use)
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.040 secs
  Preemption disabled
  Active router is 198.51.100.1, priority 105 (expires in 9.792 sec)
  Standby router is local
  Priority 100 (default 100)
  Group name is "hsrp-Gi1-0" (default)

zdefiniujmy tunel (po uprzednim przeklikaniu się przez usługę TunnelBroker w HE):

HSRP-1#sh run int tu0
!
interface Tunnel0
 no ip address
 ipv6 address 2001:DB8::2/64
 tunnel source 198.51.100.3
 tunnel mode ipv6ip
 tunnel destination 216.66.80.162 ! publiczny adres headendu HE w Warszawie
end

HSRP-2#sh run int tu0
!
interface Tunnel0
 no ip address
 ipv6 address 2001:DB8::2/64
 tunnel source 198.51.100.3
 tunnel mode ipv6ip
 tunnel destination 216.66.80.162 ! publiczny adres headendu HE w Warszawie
end

oczywiście, routing IPv6 trzeba jeszcze włączyć a następnie wskazać domyślną trasę przez interfejs Tunel0:

HSRP-1#sh running-config | i ipv6 
ipv6 unicast-routing
ipv6 route ::/0 Tunnel0

HSRP-2#sh running-config | i ipv6 
ipv6 unicast-routing
ipv6 route ::/0 Tunnel0

po takiej konfiguracji, na aktywnym routerze HSRP interfejs będzie w stanie podniesionym, a na zapasowym - położony do czasu zmiany roli w grupie:

HSRP-1#sh int tu0
Tunnel0 is up, line protocol is up 
[...]
!
HSRP-1#sh standby 
GigabitEthernet1 - Group 0
  State is Active
[...]
  Active router is local
  Standby router is 198.51.100.2, priority 100 (expires in 10.432 sec)
  Priority 105 (configured 105)
HSRP-2#sh int tu0
Tunnel0 is up, line protocol is down 
[...]
!
HSRP-2#sh standby 
GigabitEthernet1 - Group 0
  State is Standby
[...]
  Active router is 198.51.100.1, priority 105 (expires in 9.872 sec)
  Standby router is local
  Priority 100 (default 100)

i test z aktywnego routera brzegowego:

HSRP-1#ping 2001:DB8::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms